Fixed: Also check for the day prior to the epoch to account for timezone issues when...
[xbmc:xbmc-antiquated.git] / README.ubuntu
1 TOC
2 1. Introduction
3 2. Getting the source code
4 3. Installing the required Ubuntu packages
5 4. How to compile
6 5. Uninstalling
7
8 -----------------------------------------------------------------------------
9 1. Introduction
10 -----------------------------------------------------------------------------
11
12 We currently recommend Ubuntu Hardy(8.04) or later.
13 A gfx-adapter with OpenGL acceleration is highly recommended and 24/32 
14 bitdepth is required with OpenGL.
15
16 NOTE TO NEW LINUX USERS: All lines that are prefixed with the '#'
17 character are commands that need to be typed into a terminal window /
18 console (similar to the command prompt for Windows). Note that the '#'
19 character itself should NOT be typed as part of the command.
20
21 -----------------------------------------------------------------------------
22 2. Getting the source code
23 -----------------------------------------------------------------------------
24
25    # sudo apt-get install subversion
26    # cd $HOME
27    # svn checkout http://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk xbmc
28
29 -----------------------------------------------------------------------------
30 3. Installing the required Ubuntu packages
31 -----------------------------------------------------------------------------
32
33 Two methods exist to install the required Ubuntu packages:
34
35 [NOTICE] For supported old Ubuntu versions, some packages might be outdated.
36          For those, you can either compile them manually, or use our backports
37          available from our official PPA:
38
39          http://launchpad.net/~team-xbmc/+archive/ppa
40
41 --------------------------------------------------------------------
42 3.1. Copy and paste the following line corresponding to your system
43 --------------------------------------------------------------------
44
45 For Ubuntu (all versions >= 7.04):
46
47    # sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
48
49 For Ubuntu Maverick (10.10):
50    # sudo apt-get install autopoint
51
52 On 8.10 and older versions, libcurl is outdated and thus XBMC will not compile properly.
53 In this case you will have to manually compile the latest version.
54    # wget http://curl.sourceforge.net/download/curl-7.19.7.tar.gz
55    # tar -xzf curl-7.19.7.tar.gz
56    # cd curl-7.19.7
57    # ./configure --disable-ipv6 --without-libidn --disable-ldap --prefix=/usr
58    # make
59    # sudo make install
60
61 On 8.04 and older versions, libmms is outdated and thus XBMC will not compile properly.
62 In this case you will have to manually compile the latest version. See the previous [NOTICE].
63    # wget "http://launchpad.net/libmms/trunk/0.5/+download/libmms-0.5.tar.gz"
64    # tar zxvf libmms-0.5.tar.gz
65    # cd libmms-0.5
66    # ./configure --prefix=/usr
67    # make
68    # sudo make install
69
70 --------------------------------------------------------------
71 3.2. Use a single command to get all build dependencies
72 --------------------------------------------------------------
73
74 You can get all build dependencies used for building the packages on the PPA. For this, you 
75 need to specify the PPA in your apt sources. Please find the documentation on how to add a
76 PPA to your system here: 
77
78    http://launchpad.net/+help/soyuz/ppa-sources-list.html
79
80 The PPA used for XBMC (developpement version) is located on the following page:
81
82    http://launchpad.net/~team-xbmc-svn/+archive/ppa
83
84 [Note 1] Click on "Technical details about this PPA" to display the sources.list entries.
85
86 [Note 2] If you are using a distribution that has outdated libraries, do not forget to use 
87          the following ppa:
88          http://launchpad.net/~team-xbmc/+archive/ppa
89
90 Update apt:
91    # sudo apt-get update
92
93 Here is the magic command to get the build dependencies (used to compile the version on the PPA).
94    #  sudo apt-get build-dep xbmc
95
96 *** For Hardy add "deb http://ppa.launchpad.net/team-xbmc/xbmc-ppa-build-depends/ubuntu hardy main" to sources.list
97
98 *** Avoid using "aptitude" for the build-dep command. It doesn't resolve everything.
99
100 *** For developers and anyone else who compiles frequently it is recommended to use ccache
101 sudo apt-get install ccache
102
103 *** A tip for those with multiple computers at home is to check out distcc (totally unsupported from xbmc of course)
104 sudo apt-get install distcc
105
106 -----------------------------------------------------------------------------
107 4. How to compile
108 -----------------------------------------------------------------------------
109 See README.linux
110
111 -----------------------------------------------------------------------------
112 5. Uninstalling
113 -----------------------------------------------------------------------------
114 $ sudo apt-get remove xbmc*
115
116 EOF
117