WebCore: Make db.changeVersion()'s third parameter optional, as required by the spec. qtwebkit-2.1-week38
authorDumitru Daniliuc <dumi@chromium.org>
Thu, 22 Jul 2010 20:56:49 +0000 (20:56 +0000)
committerSimon Hausmann <simon.hausmann@nokia.com>
Fri, 24 Sep 2010 14:33:21 +0000 (16:33 +0200)
commit8e0cd1b3f5fb5dae7c869bc0bdc6bc10ae1410c1
tree066e25f8e382b4bb1c5bba0dd119792e782643fe
parent40a9f70a0b26496cb3933bc847c0ed5ffbf1982f
WebCore: Make db.changeVersion()'s third parameter optional, as required by the spec.
https://bugs.webkit.org/show_bug.cgi?id=42787

Reviewed by Ojan Vafai.

* bindings/js/JSDatabaseCustom.cpp:
(WebCore::JSDatabase::changeVersion):
* bindings/js/JSDatabaseSyncCustom.cpp:
(WebCore::JSDatabaseSync::changeVersion):
* bindings/v8/custom/V8DatabaseCustom.cpp:
(WebCore::V8Database::changeVersionCallback):
* bindings/v8/custom/V8DatabaseSyncCustom.cpp:
(WebCore::V8DatabaseSync::changeVersionCallback):
* storage/SQLTransaction.cpp:
(WebCore::SQLTransaction::deliverTransactionCallback):
* storage/SQLTransactionSync.cpp:
(WebCore::SQLTransactionSync::execute):

LayoutTests: Simplify some tests, and make sure db.changeVersion()'s third parameter is optional.
https://bugs.webkit.org/show_bug.cgi?id=42787

Reviewed by Ojan Vafai.

* fast/workers/storage/resources/change-version-sync-1.js:
* fast/workers/storage/resources/change-version-sync-2.js:
* storage/change-version.html:

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@63910 268f45cc-cd09-0410-ab3c-d52691b4dbfc
LayoutTests/ChangeLog
LayoutTests/fast/workers/storage/resources/change-version-sync-1.js
LayoutTests/fast/workers/storage/resources/change-version-sync-2.js
LayoutTests/storage/change-version.html
WebCore/ChangeLog
WebCore/bindings/js/JSDatabaseCustom.cpp
WebCore/bindings/js/JSDatabaseSyncCustom.cpp
WebCore/bindings/v8/custom/V8DatabaseCustom.cpp
WebCore/bindings/v8/custom/V8DatabaseSyncCustom.cpp
WebCore/storage/SQLTransaction.cpp
WebCore/storage/SQLTransactionSync.cpp