Document public API for libgstvaapi-*.so.*.
[vaapi:stormers-gstreamer-vaapi.git] / configure.ac
1 # gstreamer-vaapi package version number
2 m4_define([gst_vaapi_major_version], [0])
3 m4_define([gst_vaapi_minor_version], [1])
4 m4_define([gst_vaapi_micro_version], [1])
5 m4_define([gst_vaapi_version],
6           [gst_vaapi_major_version.gst_vaapi_minor_version.gst_vaapi_micro_version])
7
8 # gst version number
9 m4_define([gst_major_version], [0])
10 m4_define([gst_minor_version], [10])
11 m4_define([gst_micro_version], [0])
12 m4_define([gst_major_minor_version],
13           [gst_major_version.gst_minor_version])
14 m4_define([gst_version],
15           [gst_major_version.gst_minor_version.gst_micro_version])
16
17 # gst plugins-base version number
18 m4_define([gst_plugins_base_major_version], [0])
19 m4_define([gst_plugins_base_minor_version], [10])
20 m4_define([gst_plugins_base_micro_version], [0])
21 m4_define([gst_plugins_base_version],
22           [gst_plugins_base_major_version.gst_plugins_base_minor_version.gst_plugins_base_micro_version])
23
24 # libva package version number
25 m4_define([libva_sds_version_0_29], [8])
26 m4_define([libva_sds_package_version_0_29], [0.29-2+sds11])
27 m4_define([libva_sds_version_0_30], [1])
28 m4_define([libva_sds_package_version_0_30], [0.30-1+sds1])
29 m4_define([libva_glx_sds_version_0_30], [5])
30 m4_define([libva_glx_sds_package_version_0_30], [0.30.4-1+sds6])
31 m4_define([libva_glx_sds_version_0_31], [1])
32 m4_define([libva_glx_sds_package_version_0_31], [0.31.0-1+sds1])
33 m4_define([libva_sds_version], [libva_glx_sds_version_0_31])
34 m4_define([libva_sds_package_version], [libva_glx_sds_package_version_0_31])
35
36 AC_PREREQ([2.57])
37 AC_INIT([gst_vaapi], [gst_vaapi_version],
38     [gbeauchesne@splitted-desktop.com],
39     [gstreamer-vaapi])
40 AC_CONFIG_SRCDIR([Makefile.am])
41 AC_CANONICAL_TARGET
42 AM_INIT_AUTOMAKE
43 AM_CONFIG_HEADER([config.h])
44
45 TODAY="`LC_ALL=C date +'%a, %d %b %Y %X %z'`"
46 AC_SUBST(TODAY)
47
48 GST_VAAPI_MAJOR_VERSION=gst_vaapi_major_version
49 AC_SUBST(GST_VAAPI_MAJOR_VERSION)
50
51 LIBVA_SDS_PACKAGE_VERSION=libva_sds_package_version
52 AC_SUBST(LIBVA_SDS_PACKAGE_VERSION)
53
54 dnl Check for __attribute__((visibility()))
55 AC_CACHE_CHECK([whether __attribute__((visibility())) is supported],
56   vaapi_cv_visibility_attribute,
57   [cat > conftest.c <<EOF
58 int foo __attribute__ ((visibility ("hidden"))) = 1;
59 int bar __attribute__ ((visibility ("protected"))) = 1;
60 EOF
61   vaapi_cv_visibility_attribute=no
62   if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
63     if grep '\.hidden.*foo' conftest.s >/dev/null; then
64       if grep '\.protected.*bar' conftest.s >/dev/null; then
65         vaapi_cv_visibility_attribute=yes
66       fi
67     fi
68   fi
69   rm -f conftest.[cs]
70 ])
71 if test $vaapi_cv_visibility_attribute = yes; then
72   vaapi_cv_visibility_attribute_hidden="__attribute__((visibility(\"hidden\")))"
73 else
74   vaapi_cv_visibility_attribute_hidden=""
75 fi
76 AC_DEFINE_UNQUOTED([attribute_hidden],
77                    [$vaapi_cv_visibility_attribute_hidden],
78                    [Define the "hidden" visibility attribute])
79
80 dnl Versions for GStreamer and plugins-base
81 GST_MAJORMINOR=gst_major_minor_version
82 GST_VERSION_REQUIRED=gst_version
83 GST_PLUGINS_BASE_VERSION_REQUIRED=gst_plugins_base_version
84 AC_SUBST(GST_MAJORMINOR)
85
86 dnl Check for tools
87 AC_PROG_CC
88 AM_PROG_CC_C_O
89 AC_PROG_LIBTOOL
90
91 dnl Check for Gtk doc
92 GTK_DOC_CHECK([1.9])
93 AM_CONDITIONAL([BUILD_GTK_DOC], [test "x$enable_gtk_doc" = "xyes"])
94
95 dnl Check for GLib
96 PKG_CHECK_MODULES([GLIB], [glib-2.0])
97 AC_SUBST(GLIB_CFLAGS)
98 AC_SUBST(GLIB_LIBS)
99
100 dnl Check for GStreamer
101 PKG_CHECK_MODULES([GST],
102     [gstreamer-$GST_MAJORMINOR >= $GST_VERSION_REQUIRED]
103 )
104 AC_SUBST(GST_CFLAGS)
105 AC_SUBST(GST_LIBS)
106
107 dnl Check for GStreamer plugins-base
108 PKG_CHECK_MODULES([GST_PLUGINS_BASE],
109     [gstreamer-plugins-base-$GST_MAJORMINOR >= $GST_PLUGINS_BASE_VERSION_REQUIRED]
110 )
111 AC_SUBST(GST_PLUGINS_BASE_CFLAGS)
112 AC_SUBST(GST_PLUGINS_BASE_LIBS)
113
114 dnl Check for GStreamer base
115 PKG_CHECK_MODULES([GST_BASE],
116     [gstreamer-base-$GST_MAJORMINOR >= $GST_VERSION_REQUIRED]
117 )
118 AC_SUBST(GST_BASE_CFLAGS)
119 AC_SUBST(GST_BASE_LIBS)
120
121 dnl Check for GStreamer video
122 PKG_CHECK_MODULES([GST_VIDEO],
123     [gstreamer-video-$GST_MAJORMINOR >= $GST_VERSION_REQUIRED]
124 )
125 AC_SUBST(GST_VIDEO_CFLAGS)
126 AC_SUBST(GST_VIDEO_LIBS)
127
128 dnl Check for the GStreamer plugins directory
129 AC_MSG_CHECKING([for GStreamer plugins directory])
130 GST_PLUGINS_DIR=`$PKG_CONFIG gstreamer-$GST_MAJORMINOR --variable pluginsdir`
131 if test -z "$GST_PLUGINS_DIR"; then
132     echo "FAIL FAIL FAIL"
133     GST_PLUGINS_DIR="\$(libdir)/gstreamer-$GST_MAJORMINOR"
134 fi
135 AC_MSG_RESULT([$GST_PLUGINS_DIR])
136 plugindir="$GST_PLUGINS_DIR"
137 AC_SUBST(plugindir)
138
139 dnl Check for VA-API
140 PKG_CHECK_MODULES(LIBVA, [libva])
141 PKG_CHECK_MODULES(X11, [x11])
142 PKG_CHECK_MODULES(LIBVA_X11, [libva-x11])
143
144 dnl Check for SDS extensions to VA-API
145 AC_CACHE_CHECK([for VA-API],
146   ac_cv_libva_sds_extensions, [
147   saved_CFLAGS="$CFLAGS"
148   CFLAGS="$CFLAGS $LIBVA_DEPS_CFLAGS"
149   AC_TRY_COMPILE([
150     #include <va/va_version.h>
151     #if VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 29
152     # if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_SDS_VERSION_0_29)
153     #  error "VA-API version >= 0.29.0-sds$LIBVA_SDS_VERSION_0_29 is required"
154     # endif
155     #elif VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 30
156     # if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_SDS_VERSION_0_30)
157     #  error "VA-API version >= 0.30.0-sds$LIBVA_SDS_VERSION_0_30 is required"
158     # endif
159     #elif !VA_CHECK_VERSION(0,31,0)
160     # error "VA-API version >= 0.31 is required"
161     #endif
162   ], [],
163   [ac_cv_libva_sds_extensions="yes"],
164   [ac_cv_libva_sds_extensions="no"])
165   CFLAGS="$saved_CFLAGS"
166 ])
167 VA_VERSION=`$PKG_CONFIG --modversion libva`
168 VA_MAJOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f1`
169 VA_MINOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f2`
170 VA_DRIVER_INIT_FUNC="__vaDriverInit_${VA_MAJOR_VERSION}_${VA_MINOR_VERSION}_sds"
171 if test "$ac_cv_libva_sds_extensions" = "yes"; then
172     AC_DEFINE_UNQUOTED([VA_DRIVER_INIT_FUNC], [$VA_DRIVER_INIT_FUNC], [Define driver entry-point])
173 else
174     AC_MSG_ERROR([Your VA-API SDK does not include SDS extensions])
175 fi
176
177 pkgconfigdir=${libdir}/pkgconfig
178 AC_SUBST(pkgconfigdir)
179
180 AC_OUTPUT([
181     Makefile
182     debian/Makefile
183     debian/changelog
184     debian/control
185     debian/gstreamer$GST_MAJORMINOR-vaapi.install:\
186 debian/gstreamer-vaapi.install.in
187     debian/libgstvaapi$GST_VAAPI_MAJOR_VERSION.install:\
188 debian/libgstvaapi.install.in
189     debian/libgstvaapi$GST_VAAPI_MAJOR_VERSION-dev.install:\
190 debian/libgstvaapi-dev.install.in
191     debian/libgstvaapi-x11-$GST_VAAPI_MAJOR_VERSION.install:\
192 debian/libgstvaapi-x11.install.in
193     docs/Makefile
194     docs/reference/Makefile
195     docs/reference/libs/Makefile
196     docs/reference/libs/libs-docs.xml
197     gst-libs/Makefile
198     gst-libs/gst/Makefile
199     gst-libs/gst/vaapi/Makefile
200     pkgconfig/Makefile
201     pkgconfig/gstreamer-vaapi.pc
202     pkgconfig/gstreamer-vaapi-x11.pc
203     sys/Makefile
204     sys/vaapiconvert/Makefile
205     sys/vaapisink/Makefile
206     tests/Makefile
207 ])