glib: map deprecated API to glib >= 2.32 equivalents.
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>
Tue, 7 Feb 2012 10:07:15 +0000 (11:07 +0100)
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>
Tue, 7 Feb 2012 10:25:17 +0000 (11:25 +0100)
commitbfeff67c100f741b9511c05157f9f0853d78eaba
treee36c0d3880e186674432b7ff61c028646ebf5ae4
parent1fc69697eb8799d199beaa61da238495e083913f
glib: map deprecated API to glib >= 2.32 equivalents.

GStaticMutex and GStaticRecMutex are now replaced with GMutex and
GRecMutex, which no longer require any prior call to g_thread_init().
gst-libs/gst/vaapi/glibcompat.h
gst-libs/gst/vaapi/gstvaapidisplay.c