Removal of gstreamer-1.0 support
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>
Fri, 3 Apr 2015 14:09:08 +0000 (17:09 +0300)
committerSreerenj Balachandran <sreerenj.balachandran@intel.com>
Fri, 3 Apr 2015 14:09:08 +0000 (17:09 +0300)
commit8b36e25f477b165a4c1b3c08961d9bf1b51b1e4a
tree421802646f4c9a9243be29ff0b49698a8439528c
parentc561b8da8aa266963cbe8fc6e1d43984e2a44aed
Removal of gstreamer-1.0 support

The support for GStreamer 1.0 has been obsoleted in 0.5.10 release.
GStreamer 1.2 is the a minimal requirement for building the gstreamer-vaapi.

This patch removes all the pre-processor conditional code compilation guarded
for gstreamer-1.0.

Thus, all the video converters were removed too.

https://bugzilla.gnome.org/show_bug.cgi?id=745728

Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Signed-off-by: Sreerenj Balachandran <sreerenj.balachandran@intel.com>
19 files changed:
gst/vaapi/gstvaapidecode.c
gst/vaapi/gstvaapidecodebin.c
gst/vaapi/gstvaapiencode_h264.c
gst/vaapi/gstvaapiencode_jpeg.c
gst/vaapi/gstvaapiencode_mpeg2.c
gst/vaapi/gstvaapiencode_vp8.c
gst/vaapi/gstvaapipluginbase.c
gst/vaapi/gstvaapipluginutil.c
gst/vaapi/gstvaapipluginutil.h
gst/vaapi/gstvaapipostproc.c
gst/vaapi/gstvaapisink.c
gst/vaapi/gstvaapivideobuffer.c
gst/vaapi/gstvaapivideobufferpool.c
gst/vaapi/gstvaapivideocontext.c
gst/vaapi/gstvaapivideocontext.h
gst/vaapi/gstvaapivideoconverter_glx.h [deleted file]
gst/vaapi/gstvaapivideoconverter_x11.h [deleted file]
gst/vaapi/gstvaapivideomemory.h
gst/vaapi/gstvaapivideometa_texture.c