libs: fix compatibility with glib 2.28.
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>
Mon, 17 Dec 2012 08:41:24 +0000 (09:41 +0100)
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>
Mon, 17 Dec 2012 13:33:52 +0000 (14:33 +0100)
commit48f4f0564e45a5dcbf7e3543fff590943c6581e1
treebf55746c97698a5c0fd21ea06bebf094304b9dd0
parent97c3b2ddffbf87fef4f037f0b0fcb6fec273dbab
libs: fix compatibility with glib 2.28.

Always prefer non deprecated APIs by default and provide compatibility
glue for older glib versions when necessary.
gst-libs/gst/vaapi/glibcompat.h
gst/vaapi/gstvaapi.c