Bump
[tante_overlay:mainline.git] / net-misc / gwibber / gwibber-3.3.1.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/gwibber/gwibber-3.1.0.ebuild,v 1.3 2011/07/07 18:14:12 hwoarang Exp $
4
5 EAPI="3"
6 PYTHON_USE_WITH="sqlite"
7
8 inherit eutils
9
10 DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed
11 with Python and GTK."
12 HOMEPAGE="https://launchpad.net/gwibber"
13 SRC_URI="http://launchpad.net/${PN}/3.4/${PV}/+download/${P}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="-amd64 -x86"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-python/dbus-python-0.80.2
21         >=dev-python/gconf-python-2.18.0
22         dev-python/gnome-keyring-python
23         >=dev-python/imaging-1.1.6
24         >=dev-python/notify-python-0.1.1
25         >=dev-python/pywebkitgtk-1.0.1
26         >=dev-python/simplejson-1.9.1
27         >=dev-python/egenix-mx-base-3.0.0
28         >=dev-python/python-distutils-extra-2.15
29         >=dev-python/pycurl-7.19.0
30         >=dev-python/libwnck-python-2.26.0
31         >=dev-python/feedparser-4.1
32         >=dev-python/pyxdg-0.15
33         >=dev-python/mako-0.2.4
34         >=dev-python/pygtk-2.16
35         dev-python/oauth
36         >=gnome-base/librsvg-2.22.2
37         >=dev-libs/dee-0.5.22
38         net-misc/curl
39         dev-lang/vala
40         "
41
42 DOC="AUTHORS README"
43
44 src_prepare() {
45         epatch "$FILESDIR"/gwibber-twitter-api-key.patch
46         epatch "$FILESDIR"/gwibber-fix-uuid-import.patch
47         epatch "$FILESDIR"/gtkspell-pc-path.patch
48 }
49
50 src_configure() {
51         # we have no unity to build against
52         econf  --disable-unity
53 }
54
55 src_install() {
56         emake DESTDIR="${D}" prefix="/usr" install
57         elog "A new Twitter API is used. If your old accounts fail to work, try to"
58         elog "re-add them."
59 }