libnotify: add dbus-glib dependency
authorMartin Jansa <Martin.Jansa@gmail.com>
Fri, 18 Apr 2014 19:56:23 +0000 (21:56 +0200)
committerMartin Jansa <Martin.Jansa@gmail.com>
Fri, 18 Apr 2014 21:27:33 +0000 (23:27 +0200)
commit9fa17e5c5688fd5150bd585cccd91654f9972edf
tree793d1054a556e37f5356d14ffbdc2e01111e2dd7
parentf173bade24188e88a1c0c3a90ba4046df709aab2
libnotify: add dbus-glib dependency

* | No package 'dbus-glib-1' found
  | configure:11865: error: Package requirements (gtk+-2.0 >= 2.18, glib-2.0 >= 2.6,
    dbus-1 >= 0.76, dbus-glib-1 >= 0.76 gmodule-2.0) were not met:

* introduced in:
  commit 5c1eeb5d16566521e45947b07fdcd9f552fec45b
  Author: Alexandru Palalau <alexandrux.palalau@intel.com>
  Date:   Thu Feb 27 12:05:41 2014 +0200

      libnotify: don't use gnome.bbclass

  because gnome.bbclass was adding gconf->dbus-glib dependency

* it was also causing other recipes to fail when they were depending
  on libnotify which has dbus-glib in pkg-config and dbus-glib was
  missing, e.g. firefox:
  | checking for libnotify >= 0.4... Package dbus-glib-1 was not found
  in the pkg-config search path. Perhaps you should add the directory
  containing `dbus-glib-1.pc' to the PKG_CONFIG_PATH environment
  variable Package 'dbus-glib-1', required by 'libnotify', not found
  | configure: error: Library requirements (libnotify >= 0.4) not met;
  consider adjusting the PKG_CONFIG_PATH environment variable if your
  libraries are in a nonstandard prefix so pkg-config can find them.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-gnome/libnotify/libnotify_0.6.0.bb