reimplement payments system using stripe
[shapado:shapado.git] / Gemfile.lock
1 GIT
2   remote: git://github.com/dcu/mongoid_ext.git
3   revision: edcb64748380ddf6f6b7e621bec81ba7ddf7097c
4   specs:
5     mongoid_ext (0.7.0)
6       differ (>= 0.1.2)
7       encryptor (~> 1.1.3)
8       i18n
9       mongoid (~> 2.3)
10       tzinfo
11       uuidtools (>= 2.1.1)
12
13 GIT
14   remote: git://github.com/dcu/poirot.git
15   revision: 032f2549c29ad33fbbed4bf9eadc12bb41473e7c
16   specs:
17     poirot (0.0.3)
18       mustache
19       rails (> 3)
20
21 GIT
22   remote: git://github.com/dcu/tunnlr_connector.git
23   revision: cfb983ddb9a28b655e27ffa8c779498df34ded3a
24   branch: patch-1
25   specs:
26     tunnlr_connector (1.0.2)
27       highline (>= 1.5.0)
28       net-ssh (>= 2.0.15)
29
30 GIT
31   remote: git://github.com/jdpace/PDFKit.git
32   revision: f468adae4bc4e991614a0d0e0a29efeef3e817c9
33   specs:
34     pdfkit (0.5.2)
35
36 GIT
37   remote: git://github.com/kuadrosx/xapit.git
38   revision: 5e52d735649167f05e58b93b3e206838cc64d599
39   specs:
40     xapit (0.3.0)
41       rack
42
43 GIT
44   remote: git://github.com/mongoid/mongoid.git
45   revision: 305a6af10bc594a10034c478497b50126627adc5
46   branch: 2.4.0-stable
47   specs:
48     mongoid (2.4.5)
49       activemodel (~> 3.1)
50       mongo (~> 1.3)
51       tzinfo (~> 0.3.22)
52
53 GIT
54   remote: git://github.com/ricodigo/bug_hunter.git
55   revision: 103ec83b35100328b3fa91eb89d961fe5e62a85f
56   specs:
57     bug_hunter (0.2.0)
58       haml
59       launchy
60       mongoid
61       rack (>= 1.0.0)
62       sass
63       sinatra
64
65 GIT
66   remote: git://github.com/ricodigo/rdiscount.git
67   revision: 5ad5689886043e312e505585a291c85f9e50a761
68   specs:
69     rdiscount (1.6.8)
70
71 GIT
72   remote: http://github.com/dcu/multiauth.git
73   revision: 18847dbe793cbf515b34cd52ab5fa5e765107351
74   specs:
75     multiauth (0.2.7)
76       omniauth
77       rails (>= 3.0.0)
78
79 GIT
80   remote: https://git.gitorious.org/social_widgets/social_widgets.git
81   revision: e6f1f40d7027c3bd2ec50714cdb285d409170f79
82   specs:
83     social_widgets (0.1.0)
84       rails
85
86 GIT
87   remote: https://github.com/Houdini/mongo_store.git
88   revision: 46d8edc81c42110c4091d600722c8352a412a51f
89   specs:
90     mongo_store (0.3.1)
91       activesupport (>= 2.2)
92       mongo (>= 1.0)
93
94 GEM
95   remote: http://rubygems.org/
96   specs:
97     POpen4 (0.1.4)
98       Platform (>= 0.4.0)
99       open4
100     Platform (0.4.0)
101     XMLCanonicalizer (1.0.1)
102       log4r (>= 1.0.4)
103     ZenTest (4.6.2)
104     actionmailer (3.2.1)
105       actionpack (= 3.2.1)
106       mail (~> 2.4.0)
107     actionpack (3.2.1)
108       activemodel (= 3.2.1)
109       activesupport (= 3.2.1)
110       builder (~> 3.0.0)
111       erubis (~> 2.7.0)
112       journey (~> 1.0.1)
113       rack (~> 1.4.0)
114       rack-cache (~> 1.1)
115       rack-test (~> 0.6.1)
116       sprockets (~> 2.1.2)
117     activemodel (3.2.1)
118       activesupport (= 3.2.1)
119       builder (~> 3.0.0)
120     activerecord (3.2.1)
121       activemodel (= 3.2.1)
122       activesupport (= 3.2.1)
123       arel (~> 3.0.0)
124       tzinfo (~> 0.3.29)
125     activeresource (3.2.1)
126       activemodel (= 3.2.1)
127       activesupport (= 3.2.1)
128     activesupport (3.2.1)
129       i18n (~> 0.6)
130       multi_json (~> 1.0)
131     addressable (2.2.7)
132     arel (3.0.2)
133     autotest (4.4.6)
134       ZenTest (>= 4.4.1)
135     bcrypt-ruby (3.0.1)
136     bson (1.4.0)
137     bson_ext (1.4.0)
138     builder (3.0.0)
139     capistrano (2.11.2)
140       highline
141       net-scp (>= 1.0.0)
142       net-sftp (>= 2.0.0)
143       net-ssh (>= 2.0.14)
144       net-ssh-gateway (>= 1.1.0)
145     capistrano-ext (1.2.1)
146       capistrano (>= 1.0.0)
147     capybara (1.1.2)
148       mime-types (>= 1.16)
149       nokogiri (>= 1.3.3)
150       rack (>= 1.0.0)
151       rack-test (>= 0.5.4)
152       selenium-webdriver (~> 2.0)
153       xpath (~> 0.1.4)
154     capybara-webkit (0.10.0)
155       capybara (>= 1.0.0, < 1.2)
156       json
157     childprocess (0.3.1)
158       ffi (~> 1.0.6)
159     chronic (0.6.7)
160     chunky_png (1.2.5)
161     coderay (1.0.5)
162     compass (0.11.7)
163       chunky_png (~> 1.2)
164       fssm (>= 0.2.7)
165       sass (~> 3.1)
166     compass-colors (0.9.0)
167       compass (>= 0.8.7)
168     configuration (1.3.1)
169     database_cleaner (0.7.1)
170     devise (1.4.9)
171       bcrypt-ruby (~> 3.0)
172       orm_adapter (~> 0.0.3)
173       warden (~> 1.0.3)
174     diff-lcs (1.1.3)
175     differ (0.1.2)
176     domain_name (0.5.2)
177       unf (~> 0.0.3)
178     dynamic_form (1.1.4)
179     em-websocket (0.3.6)
180       addressable (>= 2.1.1)
181       eventmachine (>= 0.12.9)
182     encryptor (1.1.3)
183     erubis (2.7.0)
184     eventmachine (0.12.10)
185     execjs (1.3.0)
186       multi_json (~> 1.0)
187     fancy-buttons (1.1.1)
188       compass (>= 0.11)
189     faraday (0.7.6)
190       addressable (~> 2.2)
191       multipart-post (~> 1.1)
192       rack (~> 1.1)
193     faraday_middleware (0.7.0)
194       faraday (~> 0.7.3)
195     ffaker (1.12.1)
196     ffi (1.0.11)
197     fssm (0.2.8.1)
198     geoip (1.1.2)
199     goalie (0.0.4)
200       actionpack (>= 3.0.0)
201       activesupport (>= 3.0.0)
202     haml (3.1.4)
203     hashie (1.1.0)
204     highline (1.6.11)
205     hike (1.2.1)
206     hpricot (0.8.6)
207     i18n (0.6.0)
208     journey (1.0.3)
209     jquery-rails (2.0.0)
210       railties (>= 3.2.0.beta, < 5.0)
211       thor (~> 0.14)
212     json (1.6.5)
213     kaminari (0.13.0)
214       actionpack (>= 3.0.0)
215       activesupport (>= 3.0.0)
216       railties (>= 3.0.0)
217     kgio (2.7.2)
218     launchy (0.4.0)
219       configuration (>= 0.0.5)
220       rake (>= 0.8.1)
221     libv8 (3.3.10.4)
222     log4r (1.1.10)
223     macaddr (1.5.0)
224       systemu (>= 2.4.0)
225     machinist (1.0.6)
226     machinist_mongo (1.2.0)
227       machinist (~> 1.0.6)
228     magent (0.6.2)
229       em-websocket
230       em-websocket
231       haml (~> 3.1.1)
232       launchy (~> 0.4.0)
233       mongo
234       mongo (~> 1.0)
235       sinatra (~> 1.2.6)
236       uuidtools
237       uuidtools
238     magic (0.2.6)
239       ffi (>= 0.6.3)
240     mail (2.4.1)
241       i18n (>= 0.4.0)
242       mime-types (~> 1.16)
243       treetop (~> 1.4.8)
244     maruku (0.6.0)
245       syntax (>= 1.0.0)
246     mechanize (2.3)
247       domain_name (~> 0.5, >= 0.5.1)
248       mime-types (~> 1.17, >= 1.17.2)
249       net-http-digest_auth (~> 1.1, >= 1.1.1)
250       net-http-persistent (~> 2.5, >= 2.5.2)
251       nokogiri (~> 1.4)
252       ntlm-http (~> 0.1, >= 0.1.1)
253       webrobots (~> 0.0, >= 0.0.9)
254     method_source (0.7.0)
255     mime-types (1.17.2)
256     mini_magick (2.3)
257       subexec (~> 0.0.4)
258     mongo (1.4.0)
259       bson (= 1.4.0)
260     multi_json (1.0.4)
261     multi_xml (0.4.1)
262     multipart-post (1.1.5)
263     mustache (0.99.4)
264     net-http-digest_auth (1.2)
265     net-http-persistent (2.5.2)
266     net-ldap (0.2.2)
267     net-scp (1.0.4)
268       net-ssh (>= 1.99.1)
269     net-sftp (2.0.5)
270       net-ssh (>= 2.0.9)
271     net-ssh (2.3.0)
272     net-ssh-gateway (1.1.0)
273       net-ssh (>= 1.99.1)
274     niftier-generators (0.1.2)
275     nokogiri (1.5.0)
276     ntlm-http (0.1.1)
277     oa-basic (0.3.2)
278       oa-core (= 0.3.2)
279       rest-client (~> 1.6.0)
280     oa-core (0.3.2)
281     oa-enterprise (0.3.2)
282       XMLCanonicalizer (~> 1.0.1)
283       addressable (~> 2.2.6)
284       net-ldap (~> 0.2.2)
285       nokogiri (~> 1.5.0)
286       oa-core (= 0.3.2)
287       pyu-ruby-sasl (~> 0.0.3.1)
288       rubyntlm (~> 0.1.1)
289       uuid
290     oa-more (0.3.2)
291       multi_json (~> 1.0.0)
292       oa-core (= 0.3.2)
293       rest-client (~> 1.6.0)
294     oa-oauth (0.3.2)
295       faraday (~> 0.7.3)
296       multi_json (~> 1.0.0)
297       multi_xml (~> 0.4.0)
298       oa-core (= 0.3.2)
299       oauth (~> 0.4.0)
300       oauth2 (~> 0.5.0)
301     oa-openid (0.3.2)
302       oa-core (= 0.3.2)
303       rack-openid (~> 1.3.1)
304       ruby-openid-apps-discovery (~> 1.2.0)
305     oauth (0.4.5)
306     oauth2 (0.5.2)
307       faraday (~> 0.7)
308       multi_json (~> 1.0)
309     omniauth (0.3.2)
310       oa-basic (= 0.3.2)
311       oa-core (= 0.3.2)
312       oa-enterprise (= 0.3.2)
313       oa-more (= 0.3.2)
314       oa-oauth (= 0.3.2)
315       oa-openid (= 0.3.2)
316     open4 (1.3.0)
317     orm_adapter (0.0.6)
318     polyglot (0.3.3)
319     pry (0.9.8.2)
320       coderay (~> 1.0.5)
321       method_source (~> 0.7)
322       slop (>= 2.4.4, < 3)
323     pry-rails (0.1.6)
324       pry
325     pyu-ruby-sasl (0.0.3.3)
326     rack (1.4.1)
327     rack-cache (1.1)
328       rack (>= 0.4)
329     rack-openid (1.3.1)
330       rack (>= 1.1.0)
331       ruby-openid (>= 2.1.8)
332     rack-recaptcha (0.2.2)
333       json
334     rack-ssl (1.3.2)
335       rack
336     rack-test (0.6.1)
337       rack (>= 1.0)
338     rails (3.2.1)
339       actionmailer (= 3.2.1)
340       actionpack (= 3.2.1)
341       activerecord (= 3.2.1)
342       activeresource (= 3.2.1)
343       activesupport (= 3.2.1)
344       bundler (~> 1.0)
345       railties (= 3.2.1)
346     railties (3.2.1)
347       actionpack (= 3.2.1)
348       activesupport (= 3.2.1)
349       rack-ssl (~> 1.3.2)
350       rake (>= 0.8.7)
351       rdoc (~> 3.4)
352       thor (~> 0.14.6)
353     raindrops (0.8.0)
354     rake (0.9.2.2)
355     rdoc (3.12)
356       json (~> 1.4)
357     remarkable (4.0.0.alpha4)
358       rspec (>= 2.0.0.alpha11)
359     remarkable_activemodel (4.0.0.alpha4)
360       remarkable (~> 4.0.0.alpha4)
361       rspec (>= 2.0.0.alpha11)
362     remarkable_mongoid (0.6.0)
363       remarkable_activemodel (~> 4.0.0.alpha4)
364     rest-client (1.6.7)
365       mime-types (>= 1.16)
366     ricodigo-capistrano-recipes (0.1.8)
367       capistrano (>= 2.5.9)
368       capistrano-ext (>= 1.2.1)
369       magent
370       mongoid
371       net-ssh
372       unicorn
373     rinku (1.2.2)
374     rspec (2.8.0)
375       rspec-core (~> 2.8.0)
376       rspec-expectations (~> 2.8.0)
377       rspec-mocks (~> 2.8.0)
378     rspec-core (2.8.0)
379     rspec-expectations (2.8.0)
380       diff-lcs (~> 1.1.2)
381     rspec-mocks (2.8.0)
382     rspec-rails (2.8.1)
383       actionpack (>= 3.0)
384       activesupport (>= 3.0)
385       railties (>= 3.0)
386       rspec (~> 2.8.0)
387     ruby-openid (2.1.8)
388     ruby-openid-apps-discovery (1.2.0)
389       ruby-openid (>= 2.1.7)
390     ruby-prof (0.10.8)
391     ruby-stemmer (0.8.5)
392     ruby_parser (2.3.1)
393       sexp_processor (~> 3.0)
394     rubyntlm (0.1.1)
395     rubyzip (0.9.4)
396     sanitize (2.0.3)
397       nokogiri (>= 1.4.4, < 1.6)
398     sass (3.1.15)
399     sass-rails (3.2.4)
400       railties (~> 3.2.0)
401       sass (>= 3.1.10)
402       tilt (~> 1.3)
403     selenium-webdriver (2.19.0)
404       childprocess (>= 0.2.5)
405       ffi (~> 1.0.9)
406       multi_json (~> 1.0.4)
407       rubyzip
408     sexp_processor (3.0.10)
409     simple_oauth (0.1.5)
410     simplecov (0.6.0)
411       multi_json (~> 1.0)
412       simplecov-html (~> 0.5.3)
413     simplecov-html (0.5.3)
414     sinatra (1.2.8)
415       rack (~> 1.1)
416       tilt (>= 1.2.2, < 2.0)
417     slop (2.4.4)
418     sprockets (2.1.2)
419       hike (~> 1.2)
420       rack (~> 1.0)
421       tilt (~> 1.1, != 1.3.0)
422     state_machine (1.1.2)
423     stripe (1.6.1)
424       rest-client (~> 1.4)
425     subexec (0.0.4)
426     syntax (1.0.0)
427     systemu (2.4.2)
428     therubyracer (0.9.10)
429       libv8 (~> 3.3.10)
430     thor (0.14.6)
431     tilt (1.3.3)
432     treetop (1.4.10)
433       polyglot
434       polyglot (>= 0.3.1)
435     twitter (1.7.2)
436       faraday (~> 0.7.4)
437       faraday_middleware (~> 0.7.0)
438       hashie (~> 1.1.0)
439       multi_json (~> 1.0.0)
440       multi_xml (~> 0.4.0)
441       simple_oauth (~> 0.1.5)
442     twitter-text (1.1.8)
443       actionpack
444     twitter_oauth (0.4.3)
445       json (>= 1.1.9)
446       mime-types (>= 1.16)
447       oauth (>= 0.4.1)
448     tzinfo (0.3.31)
449     uglifier (1.2.3)
450       execjs (>= 0.3.0)
451       multi_json (>= 1.0.2)
452     unf (0.0.4)
453       unf_ext
454     unf_ext (0.0.4)
455     unicorn (4.1.1)
456       kgio (~> 2.4)
457       rack
458       raindrops (~> 0.6)
459     uuid (2.3.5)
460       macaddr (~> 1.0)
461     uuidtools (2.1.2)
462     warden (1.0.6)
463       rack (>= 1.0)
464     webrobots (0.0.13)
465     whatlanguage (1.0.0)
466     whenever (0.7.2)
467       activesupport (>= 2.3.4)
468       chronic (~> 0.6.3)
469     xapian-ruby (1.2.7.1)
470     xpath (0.1.4)
471       nokogiri (~> 1.3)
472     yui-compressor (0.9.6)
473       POpen4 (>= 0.1.4)
474
475 PLATFORMS
476   ruby
477
478 DEPENDENCIES
479   autotest
480   bson (= 1.4.0)
481   bson_ext (= 1.4.0)
482   bug_hunter!
483   capistrano
484   capybara
485   capybara-webkit
486   compass (>= 0.11.5)
487   compass-colors (= 0.9.0)
488   database_cleaner
489   devise (~> 1.4.0)
490   dynamic_form
491   em-websocket (~> 0.3.0)
492   eventmachine (~> 0.12.10)
493   fancy-buttons (= 1.1.1)
494   ffaker
495   geoip
496   goalie (~> 0.0.4)
497   haml (>= 3.1.3)
498   hpricot
499   jquery-rails
500   kaminari
501   launchy
502   machinist_mongo
503   magent (= 0.6.2)
504   magic
505   maruku
506   mechanize
507   mini_magick (~> 2.3)
508   mongo (= 1.4.0)
509   mongo_store!
510   mongoid!
511   mongoid_ext!
512   multiauth!
513   mustache
514   niftier-generators (= 0.1.2)
515   nokogiri
516   oa-oauth (~> 0.3.0)
517   oa-openid (~> 0.3.0)
518   omniauth (~> 0.3.0)
519   orm_adapter
520   pdfkit!
521   poirot!
522   pry
523   pry-rails
524   rack-recaptcha (= 0.2.2)
525   rack-ssl
526   rails (= 3.2.1)
527   rdiscount!
528   remarkable_mongoid (>= 0.5.0)
529   ricodigo-capistrano-recipes (~> 0.1.3)
530   rinku (~> 1.2.2)
531   rspec (>= 2.0.1)
532   rspec-rails (>= 2.0.1)
533   ruby-prof
534   ruby-stemmer (~> 0.8.2)
535   ruby_parser
536   rubyzip (= 0.9.4)
537   sanitize (= 2.0.3)
538   sass (>= 3.1.10)
539   sass-rails (~> 3.2.0)
540   simplecov
541   social_widgets!
542   state_machine (= 1.1.2)
543   stripe
544   therubyracer
545   tunnlr_connector!
546   twitter (= 1.7.2)
547   twitter-text (= 1.1.8)
548   twitter_oauth
549   uglifier
550   unicorn (= 4.1.1)
551   uuidtools (~> 2.1.1)
552   whatlanguage (= 1.0.0)
553   whenever
554   xapian-ruby (= 1.2.7.1)
555   xapit!
556   yui-compressor