update dependencies and fix some issues
[shapado:piglops-shapado.git] / Gemfile
1 # Edit this Gemfile to bundle your application's dependencies.
2 # This preamble is the current preamble for Rails 3 apps; edit as needed.
3 source 'http://rubygems.org'
4
5 gem 'rails', '3.0.0'
6
7 if RUBY_PLATFORM !~ /mswin|mingw/
8   gem 'rdiscount', '1.6.5'
9
10   gem "ruby-stemmer", "~> 0.8.2", :require => "lingua/stemmer"
11   gem "sanitize", "1.2.1"
12
13   gem 'magic'
14   gem 'nokogiri'
15   gem 'mechanize'
16   gem 'bson_ext', '1.0.9', :require => "bson"
17 else
18   gem "maruku", "0.6.0"
19 end
20
21 gem "bson", "1.0.9", :require => "bson"
22 gem "mongo", "1.0.9"
23
24 gem "jnunemaker-validatable", "1.8.4", :require => "validatable"
25 gem "mongo_mapper", :git => 'http://github.com/jnunemaker/mongomapper.git'
26 gem "mongomapper_ext", "0.4.0"
27
28 gem "compass", "0.10.5", :require => "compass"
29 gem "compass-colors", "0.3.1"
30 gem "fancy-buttons", "0.5.5"
31
32 gem "geoip"
33 gem "whatlanguage", "1.0.0"
34 gem "uuidtools", "2.1.1"
35 gem "magent", "0.4.2"
36
37 gem 'goalie'
38 gem 'dynamic_form'
39 gem 'haml', '~> 3.0.13'
40
41 gem "differ", "0.1.1"
42 gem "rack-recaptcha", "0.2.2", :require => "rack/recaptcha"
43
44 gem "twitter-text", "1.1.8"
45 gem 'sanitize', '1.2.1'
46
47 # devise
48 gem 'oauth2', '0.0.13'
49 gem 'devise', :git => 'http://github.com/plataformatec/devise.git'
50 #gem 'devise-mongo_mapper', :git => 'http://github.com/collectiveidea/devise-mongo_mapper.git'
51 gem 'devise_openid_authenticatable', '1.0.0.alpha7', :git => "http://github.com/nbudin/devise_openid_authenticatable.git"
52 #gem 'devise-twitter', '0.1.1'
53 gem 'multiauth', '0.1.2' #, :path => "vendor/gems/multiauth"
54
55
56 group :development do
57   gem 'hpricot'
58   gem 'ruby_parser'
59   gem 'mongrel', '1.2.0.pre2'
60   gem 'niftier-generators', '0.1.2'
61 end
62