Merge remote branch 'origin/rendering-next' into next
[shapado:cantonics-shapado.git] / Gemfile
1 # Edit this Gemfile to bundle your application's dependencies.
2 # This preamble is the current preamble for Rails 3 apps; edit as needed.
3 source 'http://rubygems.org'
4
5 gem 'rails', '3.0.1'
6
7 if RUBY_PLATFORM !~ /mswin|mingw/
8   gem 'rdiscount', '1.6.5'
9
10   gem "ruby-stemmer", "~> 0.8.2", :require => "lingua/stemmer"
11   gem "sanitize", "1.2.1"
12
13   gem 'magic'
14   gem 'nokogiri'
15   gem 'mechanize'
16 else
17   gem "maruku", "0.6.0"
18 end
19
20 # ui
21 gem "haml"
22 gem 'compass', '0.10.6.pre.1'
23 gem "compass-colors", "0.3.1"
24 gem "fancy-buttons", "0.5.5"
25 gem 'will_paginate', :git => 'git://github.com/mislav/will_paginate.git', :branch => "rails3"
26 # mongodb
27 gem 'bson', '1.1.2'
28 gem 'bson_ext', '1.1.2'
29
30 gem 'mongo', '1.1.2'
31 gem 'mongoid', '2.0.0.beta.20'
32 gem 'mongoid_ext', :git => "git://github.com/dcu/mongoid_ext.git"
33
34 # utils
35
36 gem "whatlanguage", "1.0.0"
37 gem "uuidtools", "2.1.1"
38 gem "magent", "0.5.2"
39
40 gem 'goalie', '~> 0.0.4'
41 gem 'dynamic_form'
42
43 gem "differ", "0.1.1"
44 gem "rack-recaptcha", "0.2.2", :require => "rack/recaptcha"
45
46 gem "twitter-text", "1.1.8"
47 gem 'sanitize', '1.2.1'
48
49 # authentication
50 gem 'omniauth', '~> 0.1.6'
51 gem 'multiauth', :git => "http://github.com/dcu/multiauth.git"
52
53 gem 'orm_adapter'
54 gem 'devise', :git => 'http://github.com/plataformatec/devise.git', :branch => 'omniauth', :ref => "09a46695"
55
56
57 group :scripts do
58   gem 'eventmachine', '~> 0.12.10'
59   gem 'em-websocket', '~> 0.1.4'
60   gem 'cronedit'
61 end
62
63 group :test do
64   gem "fabrication"
65   gem "autotest"
66 end
67
68 group :development do
69   gem "database_cleaner"
70   gem "rspec", ">= 2.0.1"
71   gem "fabrication"
72   gem "rspec-rails", ">= 2.0.1"
73   gem "remarkable_mongoid", ">= 0.5.0"
74   gem 'hpricot'
75   gem 'ruby_parser'
76   gem 'mongrel', '1.2.0.pre2'
77   gem 'niftier-generators', '0.1.2'
78 end
79