Check gcc's version and enable c++0x only with gcc >= 4.5.
authorGeorge Kiagiadakis <kiagiadakis.george@gmail.com>
Thu, 14 Oct 2010 18:13:56 +0000 (21:13 +0300)
committerGeorge Kiagiadakis <kiagiadakis.george@gmail.com>
Thu, 14 Oct 2010 18:13:56 +0000 (21:13 +0300)
commit213b6da6d3d97bf2949dc6379a1076c0fbbd5219
tree5fb3d0942cf6003c66bb42c26d8ffa0c7418f367
parentca89fb1e7bf25dbe6ea65a99c34e8acbfe207b64
Check gcc's version and enable c++0x only with gcc >= 4.5.

This is because the latest changes with rvalue references make
code compiled with g++ 4.4 behave improperly and cause crashes.

This commit also introduces a QTGSTREAMER_DISABLE_CXX0X variable
that can be set to TRUE from the cmake command line to disable
c++0x support, for testing/debugging purposes.
cmake/modules/FindQtGstreamer.cmake