Disable ELF interpreter check when cross-compiling
[qt:ritts-qtbase.git] / src / corelib / global / global.pri
1 # Qt kernel library base module
2
3 HEADERS +=  \
4         global/qglobal.h \
5         global/qnamespace.h \
6         global/qendian.h \
7         global/qnumeric_p.h \
8         global/qnumeric.h
9
10 SOURCES += \
11         global/qglobal.cpp \
12         global/qlibraryinfo.cpp \
13         global/qmalloc.cpp \
14         global/qnumeric.cpp
15
16 # qlibraryinfo.cpp includes qconfig.cpp
17 INCLUDEPATH += $$QT_BUILD_TREE/src/corelib/global
18
19 # Only used on platforms with CONFIG += precompile_header
20 PRECOMPILED_HEADER = global/qt_pch.h
21
22 linux*:!cross_compile:!static:!symbian-gcce:!*-armcc* {
23    QMAKE_LFLAGS += -Wl,-e,qt_core_boilerplate
24    prog=$$quote(if (/program interpreter: (.*)]/) { print $1; })
25    DEFINES += ELF_INTERPRETER=\\\"$$system(readelf -l /bin/ls | perl -n -e \'$$prog\')\\\"
26 }
27
28 # Compensate for lack of platform defines in Symbian3 and Symbian4
29 symbian {
30     DEFINES += SYMBIAN_VERSION_$$upper($$replace(SYMBIAN_VERSION,\\.,_)) \
31                S60_VERSION_$$upper($$replace(S60_VERSION,\\.,_))
32 }
33
34 include(../../../tools/shared/symbian/epocroot.pri)