Let svg plugins extend svg module v5.3.0 v5.3.0-rc1
authorRichard Moe Gustavsen <richard.gustavsen@digia.com>
Fri, 2 May 2014 08:55:14 +0000 (10:55 +0200)
committerThe Qt Project <gerrit-noreply@qt-project.org>
Fri, 2 May 2014 12:39:18 +0000 (14:39 +0200)
commitbbf16bd90285658571bc30161e9687e0cc40e387
tree71a8982a5f01e7a7f114550c712f487f68e41b4a
parentbacf4858ce11074d4be94aab45c67c4676134198
Let svg plugins extend svg module

svg plugins are by default not linked together with
QtGui since its usage is rare. But when the pro file
contains Qt += svg, then its the opposite; The
application is likely to need the svg plugins.

Many of the examples shipped with the SDK fails building
on iOS (e.g accelbubble) because of this.

Change-Id: I83873d5405fde2b3d38e836057d55fcc2ceb9b6c
Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@digia.com>
src/plugins/iconengines/svgiconengine/svgiconengine.pro
src/plugins/imageformats/svg/svg.pro