Add license files mandated by (L)GPL.
authorTimo Jyrinki <timo.jyrinki@canonical.com>
Fri, 8 Feb 2013 07:12:41 +0000 (09:12 +0200)
committerThe Qt Project <gerrit-noreply@qt-project.org>
Tue, 19 Feb 2013 12:00:53 +0000 (13:00 +0100)
commit22e940b2c97364df12dbdfb51e9fc5a8eaf8d268
tree2662495c93f4941dbb2b30c606aa80ec8d655f5f
parentcf8ef1676b70d70f5e1d2725d0b24d7df5e8cfe4
Add license files mandated by (L)GPL.

Currently only qtbase includes the required LICENSE files, which
are referred to from the code headers. The same files should
be distributed as part of all the modules as well, so that the
(L)GPL licenses are adhered.

These files were wget:d from:

https://qt.gitorious.org/qt/qtbase/blobs/raw/stable/LGPL_EXCEPTION.txt
https://qt.gitorious.org/qt/qtbase/blobs/raw/stable/LICENSE.LGPL
https://qt.gitorious.org/qt/qtbase/blobs/raw/stable/LICENSE.GPL

As an addition to above, added also LICENSE.FDL. All the modules
additionally require it, since they include at least *.qdoc files and in
some cases a couple of others.

File received via
wget http://qt.gitorious.org/qt/qtbase/blobs/raw/stable/LICENSE.FDL

Change-Id: If6ef4884fe1061767fa9d66462758d20389e9d3d
Reviewed-by: Jason McDonald <macadder1@gmail.com>
LGPL_EXCEPTION.txt [new file with mode: 0644]
LICENSE.FDL [new file with mode: 0644]
LICENSE.GPL [new file with mode: 0644]
LICENSE.LGPL [new file with mode: 0644]