Set the Qt API level to compatibility mode in all tests.
[qt:qtfeedback.git] / tests / auto / qfeedbackplugin / testplugin2 / testplugin2.pro
1 load(qt_build_config)
2
3 TARGET = qtfeedback_testplugin2
4 QT = core feedback
5
6 load(qt_plugin)
7
8 DESTDIR = $$QT.feedback.plugins/feedback
9
10 INCLUDEPATH += $$QT.feedback.includes
11
12 CONFIG += testplugin
13
14 HEADERS += qfeedbacktestplugin.h
15 SOURCES += qfeedbacktestplugin.cpp
16
17 symbian: {
18     TARGET.EPOCALLOWDLLDATA=1
19     TARGET.CAPABILITY = All -Tcb
20     TARGET = $${TARGET}$${QT_LIBINFIX}
21     load(armcc_warnings)
22
23     target.path = /sys/bin
24     INSTALLS += target
25
26     symbianplugin.sources = $${TARGET}.dll
27     symbianplugin.path = $${QT_PLUGINS_BASE_DIR}/$${PLUGIN_TYPE}
28     DEPLOYMENT += symbianplugin
29 }
30
31 target.path += $$[QT_INSTALL_PLUGINS]/feedback
32 INSTALLS += target
33 DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0