Add support for finding the version of SSL/TLS in use.
authorRichard J. Moore <rich@kde.org>
Mon, 10 Mar 2014 13:00:08 +0000 (13:00 +0000)
committerThe Qt Project <gerrit-noreply@qt-project.org>
Mon, 10 Mar 2014 21:18:23 +0000 (22:18 +0100)
commit233a2f37bfa6c896612cbf9a7db42e8e0da788f5
tree6b5df8c5aa84bfc06a7c677671eba9ab4161f5c4
parent8f17d622b0f719973fb405705087f8a36c1f0739
Add support for finding the version of SSL/TLS in use.

Previously we allowed you to specify which version(s) you wanted to use,
but did not provide access to the version that was actually negotiated.

[ChangeLog][QtNetwork][QSslSocket] Add support for finding the version
of SSL/TLS in use by a connection.

Task-number: QTBUG-28471
Change-Id: I6d50d2bc9f1ce7f98192e67992178fe7e41c0575
Reviewed-by: Peter Hartmann <phartmann@blackberry.com>
src/network/ssl/qsslconfiguration.cpp
src/network/ssl/qsslconfiguration.h
src/network/ssl/qsslconfiguration_p.h
src/network/ssl/qsslsocket.cpp
src/network/ssl/qsslsocket.h
src/network/ssl/qsslsocket_openssl.cpp
src/network/ssl/qsslsocket_openssl_p.h
src/network/ssl/qsslsocket_openssl_symbols.cpp
src/network/ssl/qsslsocket_openssl_symbols_p.h
src/network/ssl/qsslsocket_p.h