Check correctly before including SSE4.2 header.
authorMike McQuaid <mike@mikemcquaid.com>
Thu, 18 Nov 2010 05:40:36 +0000 (05:40 +0000)
committerBenjamin Poulain <benjamin.poulain@nokia.com>
Thu, 18 Nov 2010 11:14:57 +0000 (12:14 +0100)
commit9f18a1ad5ce32dd397642a4c03fa1fcb21fb9456
treee0a9cae1fe68e260a2fcb5b3779bda15877df55b
parenta01bd14b63a784d1924133aeb965435e48a93461
Check correctly before including SSE4.2 header.

Previously, this failed machines that only had SSE4.1 but not
SSE4.2 due to an assumption that nmmintrin.h could be included
when only using SSE4.1.

Fixes http://bugreports.qt.nokia.com/browse/QTBUG-13623.

Merge-request: 929
Reviewed-by: Benjamin Poulain <benjamin.poulain@nokia.com>
src/corelib/tools/qsimd_p.h