I've removed the pre-requirement that you need to have the 'bc' module
authorMicah Anderson <micah@riseup.net>
Sun, 28 Nov 2010 18:03:37 +0000 (13:03 -0500)
committerMicah Anderson <micah@riseup.net>
Sun, 28 Nov 2010 18:03:37 +0000 (13:03 -0500)
commit1455b1f9a55cdffc582fd93fa0bc5c016585760c
tree57d98a9a9f250f038a3312edc56e4b6bcbf8571d
parent735572fac73a710321b2bc469be2cbdf17c46b11
I've removed the pre-requirement that you need to have the 'bc' module
installed.

It seems a little silly to have a hard-coded dependency on a module
that simply installs one package. I replaced it with a test to see if
the package has been defined elsewhere, and if not then it installs
it, allowing those who wish to continue to do this to have no
change.

I also provide a mechanism to specify the version, if desired.

Conflicts:

manifests/linux.pp
manifests/linux.pp