merged cont.
[opensuse:yast-rest-service.git] / webyast / vendor / plugins / static_record_cache / static_record_cache.gemspec
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7   s.name = %q{static_record_cache}
8   s.version = "0.2.0"
9
10   s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11   s.authors = ["Blythe Dunham"]
12   s.date = %q{2009-12-31}
13   s.description = %q{Permanently caches subclasses of ActiveRecord in memory. }
14   s.email = %q{blythe@snowgiraffe.com}
15   s.extra_rdoc_files = [
16     "README.rdoc"
17   ]
18   s.files = [
19     ".gitignore",
20      "MIT-LICENSE",
21      "README.rdoc",
22      "Rakefile",
23      "VERSION",
24      "init.rb",
25      "install.rb",
26      "lib/acts_as_static_record.rb",
27      "lib/static_active_record_context.rb",
28      "lib/static_record_cache.rb",
29      "static_record_cache.gemspec",
30      "tasks/static_record_cache_tasks.rake",
31      "test/acts_as_static_record_test.rb",
32      "test/db/schema.rb",
33      "test/fixtures/carriers.yml",
34      "test/fixtures/phone_numbers.yml",
35      "test/models/carrier.rb",
36      "test/models/context_carrier.rb",
37      "test/models/phone_number.rb",
38      "test/static_active_record_context_test.rb",
39      "test/test_helper.rb",
40      "uninstall.rb"
41   ]
42   s.homepage = %q{http://github.com/blythedunham/static_record_cache}
43   s.rdoc_options = ["--charset=UTF-8"]
44   s.require_paths = ["lib"]
45   s.rubygems_version = %q{1.3.5}
46   s.summary = %q{Permanently caches subclasses of ActiveRecord in memory.}
47   s.test_files = [
48     "test/acts_as_static_record_test.rb",
49      "test/db/schema.rb",
50      "test/models/carrier.rb",
51      "test/models/context_carrier.rb",
52      "test/models/phone_number.rb",
53      "test/static_active_record_context_test.rb",
54      "test/test_helper.rb"
55   ]
56
57   if s.respond_to? :specification_version then
58     current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
59     s.specification_version = 3
60
61     if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
62       s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
63     else
64       s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
65     end
66   else
67     s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
68   end
69 end
70