merged cont.
[opensuse:yast-rest-service.git] / webyast / public / dispatch.cgi
1 #!/usr/bin/ruby
2 # Source: generated by rails
3
4 require File.dirname(__FILE__) + "/../config/environment" unless defined?(RAILS_ROOT)
5
6 # If you're using RubyGems and mod_ruby, this require should be changed to an absolute path one, like:
7 # "/usr/local/lib/ruby/gems/1.8/gems/rails-0.8.0/lib/dispatcher" -- otherwise performance is severely impaired
8 require "dispatcher"
9
10 ADDITIONAL_LOAD_PATHS.reverse.each { |dir| $:.unshift(dir) if File.directory?(dir) } if defined?(Apache::RubyRun)
11 Dispatcher.dispatch