remove all legacy support for pre-2.6 kernels
authorAlan Jenkins <alan-jenkins@tuffmail.co.uk>
Tue, 31 Mar 2009 12:27:07 +0000 (13:27 +0100)
committerJon Masters <jcm@jonmasters.org>
Wed, 8 Apr 2009 21:53:24 +0000 (17:53 -0400)
commite800969a24894f0965755532d792875cc4565a7c
tree7d205a4bfe9d509f02d07131d488e7854b4c9c39
parent302dcaf687975acb12d38476062daf9a5d5927b1
remove all legacy support for pre-2.6 kernels

An earlier change removed backcompat from modprobe only.  Remove
backcompat from the other commands, and update the documentation
accordingly.

This means "make install" doesn't need modprobe.old and friends.
It should make it simpler to create distribution packages.

Signed-off-by: Alan Jenkins <alan-jenkins@tuffmail.co.uk>
Signed-off-by: Jon Masters <jcm@jonmasters.org>
20 files changed:
Makefile.am
backwards_compat.c [deleted file]
depmod.c
doc/depmod.sgml
doc/insmod.sgml
doc/lsmod.sgml
doc/modinfo.sgml
doc/modprobe.conf.sgml
doc/modprobe.sgml
doc/rmmod.sgml
insmod.c
install-with-care
lsmod.c
modinfo.c
rmmod.c
tests/test-depmod/disabled_01backcompat.sh [deleted file]
tests/test-insmod/disabled01backcompat.sh [deleted file]
tests/test-lsmod/disabled02backcompat.sh [deleted file]
tests/test-modinfo/disabled01backcompat.sh [deleted file]
tests/test-rmmod/disabled01backcompat.sh [deleted file]