replace updater capabilities (ugly class) with Updater::Capabilities
authorDuncan Mac-Vicar P <dmacvicar@suse.de>
Tue, 16 Sep 2008 19:42:39 +0000 (21:42 +0200)
committerDuncan Mac-Vicar P <dmacvicar@suse.de>
Tue, 16 Sep 2008 19:42:39 +0000 (21:42 +0200)
commitbfcbdaaf8ffd8f2ca4ee167a266a5102f9f83698
tree17e13fc20a3e7f42571ce6becc5de5a3462b3cdb
parent87454c171f6ac4e2e5d6bc405c79d4212154162d
replace updater capabilities (ugly class) with Updater::Capabilities
with flag semantics (using QFlags too)
12 files changed:
src/logics.cpp
src/logics.h
src/mainwindow.cpp
src/mainwindow.h
src/notification.h
src/packagekit/packagekit_updater.cpp
src/packagekit/packagekit_updater.h
src/simpleview.cpp
src/updater.h
src/updatercapabilities.h [deleted file]
src/zypp/zyppupdater.cpp
src/zypp/zyppupdater.h