- Update Xen patches to c/s 1011.
[opensuse:kernel-source.git] / patches.xen / xen-kconfig-compat
1 From: jbeulich@novell.com
2 Subject: add 3.2.0-compatibility configure option
3 Patch-mainline: obsolete
4
5 --- sle11sp1-2010-03-29.orig/drivers/xen/Kconfig        2010-03-29 09:12:44.000000000 +0200
6 +++ sle11sp1-2010-03-29/drivers/xen/Kconfig     2010-03-29 09:12:59.000000000 +0200
7 @@ -320,6 +320,15 @@ choice
8         config XEN_COMPAT_030100_AND_LATER
9                 bool "3.1.0 and later"
10  
11 +       config XEN_COMPAT_030200_AND_LATER
12 +               bool "3.2.0 and later"
13 +
14 +       config XEN_COMPAT_030300_AND_LATER
15 +               bool "3.3.0 and later"
16 +
17 +       config XEN_COMPAT_030400_AND_LATER
18 +               bool "3.4.0 and later"
19 +
20         config XEN_COMPAT_LATEST_ONLY
21                 bool "no compatibility code"
22  
23 @@ -328,6 +337,9 @@ endchoice
24  config XEN_COMPAT
25         hex
26         default 0xffffff if XEN_COMPAT_LATEST_ONLY
27 +       default 0x030400 if XEN_COMPAT_030400_AND_LATER
28 +       default 0x030300 if XEN_COMPAT_030300_AND_LATER
29 +       default 0x030200 if XEN_COMPAT_030200_AND_LATER
30         default 0x030100 if XEN_COMPAT_030100_AND_LATER
31         default 0x030004 if XEN_COMPAT_030004_AND_LATER
32         default 0x030002 if XEN_COMPAT_030002_AND_LATER