buglabs-oe: remove concierge from build as older OSGi apis are causing compile errors...
[leafcutter:leafcutter-oe.git] / recipes / felix / felix-log_1.0.0.bb
1 require felix.inc
2
3 DESCRIPTION = "R4 Compliant OSGi logger bundle"
4
5 PR = "${INC_PR}.1"
6
7 FQPN="org.apache.felix.log"
8
9 datadir_java = ${datadir}/java/bundle/
10
11 FILES_${PN}="${datadir_java}"
12
13 addtask prep_install after do_compile before do_install
14 do_prep_install(){
15    install -m 0644 org.apache.felix.log-${PV}.jar ${S}/${BPN}.jar
16 }
17
18 SRC_URI[md5sum] = "95d51e8f9750d6f9839dbd71c0a42f26"
19 SRC_URI[sha256sum] = "1b5a71515122e2a08938a98f94188a741bfa8a1db9337669396a415a2896d85c"