llvm2.7_2.7: Add patch for build errors on newer gcc / glibc combinations
authorStefan Schmidt <stefan@buglabs.net>
Mon, 9 May 2011 07:32:24 +0000 (09:32 +0200)
committerStefan Schmidt <stefan@datenfreihafen.org>
Tue, 24 May 2011 07:03:50 +0000 (09:03 +0200)
commitbadde47cfff87d7e388a1655430061dcd8d93984
treeb207de19602f63d2d9bb790431154518d6aa1878
parenta8aa8810025e5fb3dfa5bcb94e450c3100d1f575
llvm2.7_2.7: Add patch for build errors on newer gcc / glibc combinations

Its seems there is a stricter header checking again which results in errors like
this:
error: 'ptrdiff_t' does not name a type

This happens on my Debian SID system. Adding the needed includes fixes the
build.

Signed-off-by: Stefan Schmidt <stefan@buglabs.net>
recipes/llvm/llvm2.7/include-fixes.patch [new file with mode: 0644]
recipes/llvm/llvm2.7_2.7.bb