plugins: Fix Vala plugins for valac 0.14.0
authorPhilip Withnall <philip@tecnocode.co.uk>
Sat, 22 Oct 2011 23:15:37 +0000 (00:15 +0100)
committerPhilip Withnall <philip@tecnocode.co.uk>
Sat, 22 Oct 2011 23:15:37 +0000 (00:15 +0100)
commit4632553c1e76e356876140ddc6973129048eeb91
tree21f8c0b72e5a5d6a2cbaa8e113be5b160b26915e
parent9b1a957aa66e7b86d76e5a86272a3e0f79822d96
plugins: Fix Vala plugins for valac 0.14.0

The Vala plugins were using incorrect overrides of an abstract property of
Peas.Activatable which was causing compilation to fail with valac 0.14.0.

This fixes that, and bumps our Vala dependency to 0.14.0 (since some quick
testing with valac 0.12.x didn't work due to GIR parsing problems).

Closes: bgo#662148
configure.in
src/plugins/rotation/totem-rotation-plugin.vala
src/plugins/sample-vala/totem-sample-vala-plugin.vala