intel: Fix bufmgr_gem->gen for gen > 4
authorChad Versace <chad.versace@linux.intel.com>
Fri, 27 Jan 2012 18:02:16 +0000 (10:02 -0800)
committerChad Versace <chad.versace@linux.intel.com>
Mon, 30 Jan 2012 21:03:35 +0000 (13:03 -0800)
commit592ac67626f6d69bd8b518a33e80e9c4d223eba2
tree22688a538e8c21b3b56260f7ae1ec3ed584bd90b
parentb643b0713aefdc0611e47654e88263b53b0de6f5
intel: Fix bufmgr_gem->gen for gen > 4

If the pci_device's actual gen was > 4, then we stupidly set
bufmgr_gem->gen = 6. Luckily this caused no bugs, and this fix shouldn't
change any behavior, because all checks against the gen currently have one
of the forms below:
    gen == 2
    gen == 3
    gen >= 4

Reviewed-by: Eric Anholt <eric@anholt.net>
Reviewed-by: Eugeni Dodonov <eugeni.dodonov@intel.com>
Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
intel/intel_bufmgr_gem.c