Further repo browser/Dolt integration work
[gitorious:pkong23s-mainline.git] / Gemfile
1 source "http://rubygems.org"
2
3 gem "rails", "3.2.8"
4 gem "geoip", "0.8.9"
5 gem "daemons", "1.1.0", :require => false
6 gem "rdiscount", "~> 1.6"
7 gem "mime-types", "~> 1.16", :require => "mime/types"
8 gem "diff-lcs", "1.1.2", :require => "diff/lcs"
9 gem "oauth", "0.4.4"
10 gem "paperclip", "~> 2.7"
11 gem "state_machine", "~> 1.1"
12 gem "acts-as-taggable-on", "~> 2.3"
13 gem "will_paginate", "~>3.0"
14 gem "just_paginate", "0.0.6"
15 gem "net-ldap", "~> 0.3"
16 gem "capillary", "~> 1.0.1"
17 gem "nokogiri", "~> 1.5"
18 gem "memcache-client", "~> 1.8"
19 gem "unicorn", "~> 4.3.1", :platforms => :ruby
20 gem "exception_notification", :require => "exception_notifier"
21 gem "thinking-sphinx", "~> 2.0.10"
22 gem "rails_autolink", "~> 1.0"
23 gem "mysql2"
24 gem "highline"
25
26 group :openid do
27   gem "ruby-yadis", "0.3.4", :require => "yadis"
28   gem "ruby-openid", :require => "openid"
29   gem "gitorious_openid_auth", "~> 1.1"
30 end
31
32 group :test do
33   gem "mocha", "0.9.10", :require => false
34   gem "factory_girl_rails", "~> 1.7"
35   gem "shoulda", "~> 3.3"
36   gem "rots", :git => "https://github.com/roman/rots.git"
37   gem "capybara", "1.0.1"
38   gem "launchy", "2.0.5" # used only for Capybara's save_and_open_page for launching the browser
39   gem "minitest", "4.2.0"
40 end
41
42 group :postgres do
43   gem "pg"
44 end
45
46 group :development do
47   gem "foreman", "~> 0.41"
48   gem "thin", "~> 1.2"
49 end
50
51 group :git_proxy do
52   gem "proxymachine", "1.2.4"
53   gem "rake", "~> 0.9"
54 end
55
56 group :messaging do
57   gem "json", "~> 1.5", :platforms => :ruby_18
58 end
59
60 group :resque do
61   gem "resque", "1.9.8"
62 end
63
64 group :http_utils do
65   gem "httparty", "~> 0.9"
66 end
67
68 group :dolt do
69   gem "libdolt", "~> 0.12"
70   gem "dolt", "~> 0.9"
71   gem "tiltout", "~> 1.4"
72 end
73
74 platform :jruby do
75   gem "activerecord-jdbcmysql-adapter"
76   gem "jruby-openssl"
77   gem 'trinidad', :require => false
78 end
79
80 platform :ruby_18 do
81   gem "ruby-hmac", "0.4.0"
82   gem "oniguruma", "~> 1.1"
83   gem "SystemTimer", "~> 1.2"
84 end