Updated to latest rspec
[gitorious:georgyos-clone.git] / vendor / plugins / rspec-rails / lib / spec / rails / version.rb
1 module Spec\r
2   module Rails\r
3     module VERSION #:nodoc:\r
4       BUILD_TIME_UTC = 20080528130840\r
5     end\r
6   end\r
7 end\r
8 \r
9 # Verify that the plugin has the same revision as RSpec\r
10 if Spec::Rails::VERSION::BUILD_TIME_UTC != Spec::VERSION::BUILD_TIME_UTC\r
11   raise <<-EOF\r
12 \r
13 ############################################################################\r
14 Your RSpec on Rails plugin is incompatible with your installed RSpec.\r
15 \r
16 RSpec          : #{Spec::VERSION::BUILD_TIME_UTC}\r
17 RSpec on Rails : #{Spec::Rails::VERSION::BUILD_TIME_UTC}\r
18 \r
19 Make sure your RSpec on Rails plugin is compatible with your RSpec gem.\r
20 See http://rspec.rubyforge.org/documentation/rails/install.html for details.\r
21 ############################################################################\r
22 EOF\r
23 end\r