Support caching of LDAP group member lookups
[gitorious:bclow-gitorious.git] / Gemfile
1 source "http://rubygems.org"
2
3 #gem "rails", "~> 2.3.5"
4 gem "chronic", "0.3.0"
5 gem "geoip", "0.8.9"
6 gem "daemons", "1.1.0", :require => false
7 gem "hoe", "2.8.0", :require => false
8 gem "echoe", "4.3.1", :require => false
9 gem "ruby-yadis", "0.3.4", :require => "yadis"
10 gem "ruby-openid", :require => "openid"
11 gem "rdiscount", "1.3.1.1", :platforms => :ruby
12 gem "mime-types", "1.16", :require => "mime/types"
13 gem "diff-lcs", "1.1.2", :require => "diff/lcs"
14 gem "oauth", "0.4.4"
15 gem "paperclip", "~> 2.4.5"
16 gem "state_machine", "0.9.4"
17 gem "rack", "~> 1.0.1"
18 gem "riddle", "1.2.2" # For the ultrasphinx plugin
19 gem "builder", "3.0.0"
20 gem "mysql", "2.8.1", :platforms => :ruby
21 gem "validates_url_format_of", "0.1.1"
22 gem "acts-as-taggable-on", "2.0.6"
23 gem "will_paginate", "2.3.15"
24 gem "just_paginate", "0.0.6"
25 gem "hodel_3000_compliant_logger", "0.1.0"
26 gem "net-ldap", "~> 0.3"
27 gem "capillary", "~> 1.0.1"
28 gem "nokogiri", "1.5.0"
29 gem "unicorn", "~> 4.3.1", :platforms => :ruby
30
31 # TODO: replace the lines below while upgrading to Rails 3
32 # gem "exception_notification", :require => 'exception_notifier'
33 gem "exception_notification", "~> 1.0.20090728", :require => 'exception_notifier'
34 # gem "bartt-ssl_requirement" # TODO: use this with Rails 3
35 gem "revo-ssl_requirement", "1.1.0"
36
37 # Ruby 1.8 gems
38 gem "ruby-hmac", "0.4.0", :platforms => :ruby_18
39
40 group :test do
41   gem "mocha", "0.9.10", :require => false
42   gem "factory_girl", "~> 1.3.0"
43   gem "shoulda", "~> 2.9.1"
44   gem "tuxml", "0.0.1"
45   gem "rots", :git => 'https://github.com/roman/rots.git'
46   gem "capybara", "1.0.1"
47   gem "launchy", "2.0.5" # used only for Capybara's save_and_open_page for launching the browser
48 end
49
50 group :development do
51   gem "foreman", "~> 0.41"
52   gem "stompserver", "~> 0.9"
53   gem "thin", "~> 1.2"
54 end
55
56 group :git_proxy do
57   gem "proxymachine", "1.2.4"
58   gem "rake", "0.8.7"
59 end
60
61 group :messaging do
62   gem "json", "~> 1.5.1", :platforms => :ruby_18
63 end
64
65 group :resque do
66   gem "resque", "1.9.8"
67   gem "SystemTimer", "1.2.3"
68 end
69
70 group :stomp do
71   gem "stomp", "1.1"
72 end
73
74 group :active_messaging do
75   gem "activemessaging", "0.7.1"
76 end
77
78 platform :jruby do
79   gem "activerecord-jdbcmysql-adapter"
80 end