Remove troublesome and unused dependency
[gitorious:bclow-gitorious.git] / Gemfile
1 source "http://rubygems.org"
2
3 #gem "rails", "~> 2.3.5"
4 gem "chronic"
5 gem "geoip"
6 gem "daemons", :require => false
7 gem "hoe", :require => false
8 gem "echoe", :require => false
9 gem "ruby-yadis", :require => "yadis"
10 gem "ruby-openid", :require => "openid"
11 gem "rdiscount", "1.3.1.1", :platforms => :ruby
12 gem "mime-types", :require => "mime/types"
13 gem "diff-lcs", :require => "diff/lcs"
14 gem "oauth"
15 gem "paperclip", "~> 2.4.5"
16 gem "state_machine"
17 gem "rack", "~> 1.0.1"
18 gem "riddle" # For the ultrasphinx plugin
19 gem "builder"
20 gem "mysql", :platforms => :ruby
21 gem "validates_url_format_of"
22 gem "acts-as-taggable-on"
23 gem "will_paginate"
24 gem "hodel_3000_compliant_logger"
25 gem "ruby-net-ldap", "~> 0.0.4"
26 gem "capillary", "~> 1.0.0"
27 gem "nokogiri"
28
29 # TODO: replace the lines below while upgrading to Rails 3
30 # gem "exception_notification", :require => 'exception_notifier'
31 gem "exception_notification", "~> 1.0.20090728", :require => 'exception_notifier'
32 # gem "bartt-ssl_requirement" # TODO: use this with Rails 3
33 gem "revo-ssl_requirement"
34
35 # Ruby 1.8 gems
36 gem "ruby-hmac", :platforms => :ruby_18
37
38 group :test do
39   gem "mocha", :require => false
40   gem "factory_girl", "~> 1.3.0"
41   gem "shoulda", "~> 2.9.1"
42   gem "tuxml"
43   gem "capybara"
44
45   gem "launchy" # used only for Capybara's save_and_open_page for launching the browser
46 end
47
48 group :git_proxy do
49   gem "proxymachine"
50   gem "rake"
51 end
52
53 group :messaging do
54   gem "json", "~> 1.5.1", :platforms => :ruby_18
55 end
56
57 group :resque do
58   gem "resque"
59   gem "SystemTimer"
60 end
61
62 group :stomp do
63   gem "stomp", "1.1"
64 end
65
66 group :active_messaging do
67   gem "activemessaging"
68 end
69
70 platform :jruby do
71   gem "activerecord-jdbcmysql-adapter"
72 end