Use the official Rails repo for 2.3-stable
[gitorious:bclow-gitorious.git] / Gemfile
1 source "http://rubygems.org"
2
3 # Last released version of Rails 2.3 is 2.3.15, which does not address
4 # all known security vulnerabilities.
5 git "git://github.com/rails/rails.git", :branch => "2-3-stable" do
6   gem "rails"
7   gem "actionmailer"
8   gem "actionpack"
9   gem "activerecord"
10   gem "activeresource"
11   gem "activesupport"
12 end
13
14 gem "chronic", "0.3.0"
15 gem "geoip", "0.8.9"
16 gem "daemons", "1.1.0", :require => false
17 gem "hoe", "2.8.0", :require => false
18 gem "echoe", "4.3.1", :require => false
19 gem "ruby-yadis", "0.3.4", :require => "yadis"
20 gem "ruby-openid", :require => "openid"
21 gem "rdiscount", "1.3.1.1", :platforms => :ruby
22 gem "mime-types", "1.16", :require => "mime/types"
23 gem "diff-lcs", "1.1.2", :require => "diff/lcs"
24 gem "oauth", "0.4.4"
25 gem "paperclip", "~> 2.7.2"
26 gem "state_machine", "0.9.4"
27
28 gem "builder", "3.0.0"
29 gem "mysql", "2.8.1", :platforms => :ruby
30 gem "validates_url_format_of", "0.1.1"
31 gem "acts-as-taggable-on", "2.0.6"
32 gem "will_paginate", "2.3.15"
33 gem "just_paginate", "0.0.6"
34 gem "hodel_3000_compliant_logger", "0.1.0"
35 gem "net-ldap", "~> 0.3"
36 gem "capillary", "~> 1.0.1"
37 gem "nokogiri", "1.5.0"
38 gem "unicorn", "~> 4.3.1", :platforms => :ruby
39
40 gem "thinking-sphinx", "~> 1.4.13"
41
42 # TODO: replace the lines below while upgrading to Rails 3
43 # gem "exception_notification", :require => 'exception_notifier'
44 gem "exception_notification", "~> 1.0.20090728", :require => 'exception_notifier'
45 # gem "bartt-ssl_requirement" # TODO: use this with Rails 3
46 gem "revo-ssl_requirement", "1.1.0"
47
48 # Ruby 1.8 gems
49 gem "ruby-hmac", "0.4.0", :platforms => :ruby_18
50
51 group :test do
52   gem "mocha", "0.9.10", :require => false
53   gem "factory_girl", "~> 1.3.0"
54   gem "shoulda", "~> 2.9.1"
55   gem "tuxml", "0.0.1"
56   gem "rots", :git => 'https://github.com/roman/rots.git'
57   gem "capybara", "1.0.1"
58   gem "launchy", "2.0.5" # used only for Capybara's save_and_open_page for launching the browser
59 end
60
61 group :development do
62   gem "foreman", "~> 0.41"
63   gem "stompserver", "~> 0.9"
64   gem "thin", "~> 1.2"
65 end
66
67 group :git_proxy do
68   gem "proxymachine", "1.2.4"
69   gem "rake", "0.8.7"
70 end
71
72 group :messaging do
73   gem "json", "~> 1.5.1", :platforms => :ruby_18
74 end
75
76 group :resque do
77   gem "resque", "1.9.8"
78   gem "SystemTimer", "1.2.3"
79 end
80
81 group :stomp do
82   gem "stomp", "1.1"
83 end
84
85 group :active_messaging do
86   gem "activemessaging", "0.7.1"
87 end
88
89 platform :jruby do
90   gem "activerecord-jdbcmysql-adapter"
91 end