Resolve merge conflict
[gitorious:bclow-gitorious.git] / Gemfile
1 source "http://rubygems.org"
2
3 #gem "rails", "~> 2.3.5"
4 gem "chronic"
5 gem "geoip"
6 gem "daemons", :require => false
7 gem "hoe", :require => false
8 gem "echoe", :require => false
9 gem "ruby-yadis", :require => "yadis"
10 gem "ruby-openid", :require => "openid"
11 gem "rdiscount", "1.3.1.1", :platforms => :ruby
12 gem "stomp", "1.1"
13 gem "mime-types", :require => "mime/types"
14 gem "diff-lcs", :require => "diff/lcs"
15 gem "oauth"
16 gem "paperclip", "~> 2.2.8"
17 gem "state_machine"
18 gem "rack", "~> 1.0.1"
19 gem "riddle" # For the ultrasphinx plugin
20 gem "builder"
21 gem "mysql", :platforms => :ruby
22 gem "oauth"
23 gem "validates_url_format_of"
24 gem "acts-as-taggable-on"
25 gem "will_paginate"
26
27 # TODO: replace the lines below while upgrading to Rails 3
28 # gem "exception_notification", :require => 'exception_notifier'
29 gem "exception_notification", "~> 1.0.20090728", :require => 'exception_notifier'
30 # gem "bartt-ssl_requirement" # TODO: use this with Rails 3
31 gem "revo-ssl_requirement"
32
33 # Ruby 1.8 gems
34 gem "ruby-hmac", :platforms => :ruby_18
35 gem "json", :platforms => :ruby_18
36
37 group :test do
38   gem "mocha", :require => false
39   gem "factory_girl", "~> 1.3.0"
40   gem "shoulda", "~> 2.9.1"
41 end
42
43 group :git_proxy do
44   gem "proxymachine"
45   gem "rake"
46 end