Bugfix: make sure to require yaml in bin/setup
[gitorious:bclow-gitorious.git] / Gemfile
1 source "http://rubygems.org"
2
3 gem "rails", "2.3.18"
4 gem "rdoc"
5 gem "chronic", "0.3.0"
6 gem "geoip", "0.8.9"
7 gem "daemons", "1.1.0", :require => false
8 gem "hoe", "2.8.0", :require => false
9 gem "echoe", "4.3.1", :require => false
10 gem "ruby-yadis", "0.3.4", :require => "yadis"
11 gem "ruby-openid", :require => "openid"
12 gem "rdiscount", "1.3.1.1", :platforms => :ruby
13 gem "mime-types", "1.16", :require => "mime/types"
14 gem "diff-lcs", "1.1.2", :require => "diff/lcs"
15 gem "oauth", "0.4.4"
16 gem "paperclip", "~> 2.7.2"
17 gem "state_machine", "0.9.4"
18
19 gem "builder", "3.0.0"
20 gem "mysql", "2.8.1", :platforms => :ruby
21 gem "validates_url_format_of", "0.1.1"
22 gem "acts-as-taggable-on", "2.0.6"
23 gem "will_paginate", "2.3.15"
24 gem "just_paginate", "0.0.6"
25 gem "hodel_3000_compliant_logger", "0.1.0"
26 gem "net-ldap", "~> 0.3"
27 gem "capillary", "~> 1.0.1"
28 gem "nokogiri", "1.5.0"
29 gem "unicorn", "~> 4.3.1", :platforms => :ruby
30
31 gem "thinking-sphinx", "~> 1.4.13"
32
33 # TODO: replace the lines below while upgrading to Rails 3
34 # gem "exception_notification", :require => 'exception_notifier'
35 gem "exception_notification", "~> 1.0.20090728", :require => 'exception_notifier'
36 # gem "bartt-ssl_requirement" # TODO: use this with Rails 3
37 gem "revo-ssl_requirement", "1.1.0"
38
39 # Ruby 1.8 gems
40 gem "ruby-hmac", "0.4.0", :platforms => :ruby_18
41
42 group :test do
43   gem "mocha", "0.9.10", :require => false
44   gem "factory_girl", "~> 1.3.0"
45   gem "shoulda", "~> 2.9.1"
46   gem "tuxml", "0.0.1"
47   gem "rots", :git => 'https://github.com/roman/rots.git'
48   gem "capybara", "1.0.1"
49   gem "launchy", "2.0.5" # used only for Capybara's save_and_open_page for launching the browser
50 end
51
52 group :development do
53   gem "foreman", "~> 0.41"
54   gem "stompserver", "~> 0.9"
55   gem "thin", "~> 1.2"
56 end
57
58 group :git_proxy do
59   gem "proxymachine", "1.2.4"
60   gem "rake", "0.8.7"
61 end
62
63 group :messaging do
64   gem "json", ">= 1.7.7", "< 1.8", :platforms => :ruby_18
65 end
66
67 group :resque do
68   gem "resque", "1.9.8"
69   gem "SystemTimer", "1.2.3"
70 end
71
72 group :stomp do
73   gem "stomp", "1.1"
74 end
75
76 group :active_messaging do
77   gem "activemessaging", "0.7.1"
78 end
79
80 platform :jruby do
81   gem "activerecord-jdbcmysql-adapter"
82 end