Mtp: Remove LIBMTP8 conditional compilation
authorBertrand Lorentz <bertrand.lorentz@gmail.com>
Sun, 8 Jan 2012 14:03:50 +0000 (15:03 +0100)
committerBertrand Lorentz <bertrand.lorentz@gmail.com>
Sun, 8 Jan 2012 14:03:50 +0000 (15:03 +0100)
commit1efe7c2edc4c63ba95823fd3c1a102e4a4f6352f
treec4409a52c3c1a3e8bfd1fa71c3f81180e43474c0
parentf791d66d2403177d554c2f24a47395275b73dbf7
Mtp: Remove LIBMTP8 conditional compilation

We already require libmtp >= 0.3.0, which provides libmtp.so.8, so we
don't need to do any #ifdefs for that anymore.

This also fixes bgo#667478, as the configure test was broken for
libmtp.so.9 provided by libmtp 1.1.
build/m4/banshee/dap-mtp.m4
src/Libraries/Mtp/Makefile.am
src/Libraries/Mtp/Mtp/Album.cs
src/Libraries/Mtp/Mtp/File.cs
src/Libraries/Mtp/Mtp/Folder.cs
src/Libraries/Mtp/Mtp/Playlist.cs
src/Libraries/Mtp/Mtp/Track.cs